I can't see the game time, or my players in the players list!


NomadSoft Owner/Developer
Staff member
Oct 11, 2011
Hillsboro, OR
RAT requires the latest Alloc's Server Fixes for some of its functionality, please make sure that is installed. To check if it is installed correctly, connect RAT to your game server and in the console window type: version
You should see a list come back and you should have the following versions (or higher) for Alloc's:

Mod Allocs command extensions: 22 Mod Allocs server fixes: 24 Mod Allocs MapRendering and Webinterface: 39

Alloc's uses your Control Panel Port + 2, to communicate. Even if you are only using RAT as a remote connection, you need to set this. So in RAT, set your control panel port, default value of 8080 is fine, but set it to whatever you want. Remember, whatever you set it to, internally Alloc's will add +2 to it.


(Meaning RAT and your game server are on DIFFERENT machines/IPs)​
You will need to open the port so RAT can access Allocs on your server. So open Control Panel Port +2.​


In the RAT console type: webtokens list
Get the token for ratuser.
Replace <yourtoken> below with that token
Replace <control_panel_port+2> below with whatever you have set for your control panel port + 2


You should get a response like this:


Be aware, that every time you reconnect via Telnet in RAT, RAT will generate a new admin token for security.
Do NOT share this token with anyone, it will never be needed by anyone else.
There is no explanation what to do with the web address. I pasted it into a browser and got a response. Only when reading other threads I guessed you needed to Reset Alloc's token in the RAT Settings, after that it doesnt seem to complain anymore. Might be worth adding if thats the correct step.
Also, on a newly installed server the webpermissions.xml is completely commented out.